summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:18:41 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:40 +0200
commitd536011e0b726888da745598d1afbdb8ff147010 (patch)
tree5d52b145a70ec1f7f4b67fc88f63404309c71e93
parentdc887a8c1f7702c73c43a0c851a560207e692006 (diff)
gnu: Add texlive-patgen.
* gnu/packages/tex.scm (texlive-patgen): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 82085c496c..4d34f1d1f7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2946,6 +2946,26 @@ source code with highlighted words using several colors, so they see what is
considered as word, header etc.")
(license license:expat)))
+(define-public texlive-patgen
+ (package
+ (name "texlive-patgen")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/patgen.1"
+ "doc/man/man1/patgen.man1.pdf")
+ (base32
+ "03y05mv0n04hyj0lcq54grx7w5wv95h61j6xlx2jc9v0ib9akq4y")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs (list texlive-kpathsea))
+ (home-page "https://ctan.org/pkg/patgen")
+ (synopsis "Generate hyphenation patterns")
+ (description
+ "Patgen takes a list of hyphenated words and generates a set of patterns
+that can be used by the TeX 82 hyphenation algorithm.")
+ (license license:public-domain)))
+
(define-public texlive-tex-ini-files
(package
(name "texlive-tex-ini-files")