summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-11 02:39:32 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-31 13:15:24 -0400
commitea2e0eb36bf63da2628e6ed0d1f30dc5e789b969 (patch)
treeb8d9a2252a0a76fa5c11939c7ecb81b3c315ebd1
parentc82c6807e87736f839faebc51604f8abd7268228 (diff)
gnu: Add python-pyavm.
* gnu/packages/astronomy.scm (python-pyavm): New variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/astronomy.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 74e9cb753b..ded7859133 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2166,6 +2166,29 @@ cases for which diffractive rather than geometric optics is the topic of
interest, and which require portability between platforms or ease of scripting.")
(license license:bsd-3)))
+(define-public python-pyavm
+ (package
+ (name "python-pyavm")
+ (version "0.9.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "PyAVM" version))
+ (sha256
+ (base32 "0vgjqvddq4a5lnmg8msm7fwqs3r6fc748xzvnhyvc387h0z8pdxk"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-astropy python-numpy))
+ (native-inputs
+ (list python-pillow python-pytest python-setuptools-scm))
+ (home-page "https://astrofrog.github.io/pyavm/")
+ (synopsis "Simple pure-python AVM meta-data handling")
+ (description
+ "PyAVM is a module to represent, read, and write metadata following the
+@acronym{AVM, Astronomy Visualization Metadata} standard provided by
+@url{https://www.virtualastronomy.org/avm_metadata.php, vamp} project.")
+ (license license:expat)))
+
(define-public python-pyvo
(package
(name "python-pyvo")