summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-28 19:03:12 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-29 14:09:23 -0400
commiteaf79d319dd785b1d8b213ffa4dc6a3a338434e8 (patch)
tree5533ad7919ade86cba6ab66610dc3e731d36ed92
parent868113126c89ecb7f928c49de893122fa0fe272c (diff)
build: Build the guix.pot-update and contributing.pot-update targets only once.
* po/doc/local.mk (doc-pot-update): Fix an issue where guix.pot-update an contributing.pot-update were built twice.
-rw-r--r--po/doc/local.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/po/doc/local.mk b/po/doc/local.mk
index a11c74e536..90cb6a79bb 100644
--- a/po/doc/local.mk
+++ b/po/doc/local.mk
@@ -95,9 +95,8 @@ $(srcdir)/po/doc/%.pot-update: doc/%.texi
TMP_POT_FILES = contributing.pot guix.pot
doc-pot-update:
- for f in $(TMP_POT_FILES); do \
- $(MAKE) $(srcdir)/po/doc/guix.pot-update; \
- $(MAKE) $(srcdir)/po/doc/contributing.pot-update; \
+ for f in $(TMP_POT_FILES); do \
+ $(MAKE) $(srcdir)/po/doc/$$f-update; \
done
$(MAKE) $(srcdir)/po/doc/guix-cookbook.pot-update;
msgcat $(addprefix $(srcdir)/po/doc/, $(TMP_POT_FILES)) > $(srcdir)/po/doc/guix-manual.pot