summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 10:25:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:48 +0300
commitf0e0b9a55ac39da37bd0c75d7df6528118eba8cd (patch)
tree368629df192a06dbbfde6a222be5b1efdd65c34d
parentcc54d4b6e2addd437aea70dd47632191cfb98645 (diff)
gnu: julia-jpegturbo-jll: Move to (gnu packages julia-jll).
* gnu/packages/julia-xyz.scm (julia-jpegturbo-jll): Move to ... * gnu/packages/julia-jll.scm: ... here.
-rw-r--r--gnu/packages/julia-jll.scm38
-rw-r--r--gnu/packages/julia-xyz.scm37
2 files changed, 38 insertions, 37 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 062e504034..0357ead64b 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -26,6 +26,7 @@
#:use-module (guix build-system julia)
#:use-module (gnu packages)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages image)
#:use-module (gnu packages julia)
#:use-module (gnu packages web))
@@ -155,3 +156,40 @@ build tree Yggdrasil.")
to generate themselves. It is not intended to be used by users, but rather is
used in autogenerated packages via @code{BinaryBuilder.jl}.")
(license license:expat)))
+
+(define-public julia-jpegturbo-jll
+ (package
+ (name "julia-jpegturbo-jll")
+ (version "2.0.1+2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/JpegTurbo_jll.jl")
+ (commit (string-append "JpegTurbo-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xp1x0hrj337bgwwffwpyq7xg031j2a38fim29lixqa0a0y80x6y"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("artifact\"JpegTurbo\"")
+ (string-append "\"" (assoc-ref inputs "libjpeg-turbo") "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("libjpeg-turbo" ,libjpeg-turbo)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)))
+ (home-page "https://github.com/JuliaBinaryWrappers/JpegTurbo_jll.jl")
+ (synopsis "Libjpeg-turbo library wrappers")
+ (description "This package provides a wrapper for the libjpeg-turbo library.")
+ (license license:expat)))
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 49439ae0a2..2a49cf5d6a 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -993,43 +993,6 @@ external IRs. It can be used with Julia metaprogramming tools such as
Cassette.")
(license license:expat)))
-(define-public julia-jpegturbo-jll
- (package
- (name "julia-jpegturbo-jll")
- (version "2.0.1+2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/JuliaBinaryWrappers/JpegTurbo_jll.jl")
- (commit (string-append "JpegTurbo-v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1xp1x0hrj337bgwwffwpyq7xg031j2a38fim29lixqa0a0y80x6y"))))
- (build-system julia-build-system)
- (arguments
- '(#:tests? #f ; no runtests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
- (lambda* (#:key inputs #:allow-other-keys)
- (map
- (lambda (wrapper)
- (substitute* wrapper
- (("artifact\"JpegTurbo\"")
- (string-append "\"" (assoc-ref inputs "libjpeg-turbo") "\""))))
- ;; There's a Julia file for each platform, override them all
- (find-files "src/wrappers/" "\\.jl$")))))))
- (inputs
- `(("libjpeg-turbo" ,libjpeg-turbo)))
- (propagated-inputs
- `(("julia-jllwrappers" ,julia-jllwrappers)))
- (home-page "https://github.com/JuliaBinaryWrappers/JpegTurbo_jll.jl")
- (synopsis "Libjpeg-turbo library wrappers")
- (description "This package provides a wrapper for the libjpeg-turbo library.")
- (license license:expat)))
-
(define-public julia-json
(package
(name "julia-json")