summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 17:38:20 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-27 22:51:59 +0000
commit0330bb8b68bc9cf6a86ddbfdd096abef4526e77e (patch)
tree81c891613f85f86aa376cf1edea1e58d178f511b /gnu/packages/astronomy.scm
parent6b0551a6bb890fd64490c933b697fc4ff321f3de (diff)
gnu: python-sunpy: Speed up tests and relax requirements.
* gnu/packages/astronomy.scm (python-sunpy): Enable parallel tests to speed them up. [arguments] <#:test-flags>: Add it with "-n" option. <#:phases>: Add 'relax-requirements. Change-Id: I67c3308b8c5e9b878377f2175f74f1c469a43610
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm24
1 files changed, 16 insertions, 8 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 69b2af63d7..f8274e7a59 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2591,16 +2591,24 @@ orbits described in TLE files.")
(arguments
(list
#:test-flags
- #~(list "-k" (string-append
- ;; XXX: Failed: DID NOT RAISE <class 'ModuleNotFoundError'>
- ;; It struggles to find python-opencsv package info with
- ;; 'importlib.metadata'
- "not test_main_nonexisting_module"
- " and not test_main_stdlib_module")
- ;; Requries SpicePy not packed in Guix yet.
- "--ignore=sunpy/coordinates/tests/test_spice.py")
+ #~(list
+ "-n" "auto"
+ "-k" (string-append
+ ;; XXX: Failed: DID NOT RAISE <class 'ModuleNotFoundError'>
+ ;; It struggles to find python-opencsv package info with
+ ;; 'importlib.metadata'
+ "not test_main_nonexisting_module"
+ " and not test_main_stdlib_module")
+ ;; Requries SpicePy not packed in Guix yet.
+ "--ignore=sunpy/coordinates/tests/test_spice.py")
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "setup.cfg"
+ ;; It's already updated in master branch, but not released yet.
+ ;; drms>=0.6.1,<0.7.0
+ (("0.7.0") "0.7.2"))))
(add-before 'install 'writable-compiler
(lambda _
(make-file-writable "sunpy/_compiler.c")))