summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm24
1 files changed, 16 insertions, 8 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 69b2af63d7..f8274e7a59 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2591,16 +2591,24 @@ orbits described in TLE files.")
(arguments
(list
#:test-flags
- #~(list "-k" (string-append
- ;; XXX: Failed: DID NOT RAISE <class 'ModuleNotFoundError'>
- ;; It struggles to find python-opencsv package info with
- ;; 'importlib.metadata'
- "not test_main_nonexisting_module"
- " and not test_main_stdlib_module")
- ;; Requries SpicePy not packed in Guix yet.
- "--ignore=sunpy/coordinates/tests/test_spice.py")
+ #~(list
+ "-n" "auto"
+ "-k" (string-append
+ ;; XXX: Failed: DID NOT RAISE <class 'ModuleNotFoundError'>
+ ;; It struggles to find python-opencsv package info with
+ ;; 'importlib.metadata'
+ "not test_main_nonexisting_module"
+ " and not test_main_stdlib_module")
+ ;; Requries SpicePy not packed in Guix yet.
+ "--ignore=sunpy/coordinates/tests/test_spice.py")
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "setup.cfg"
+ ;; It's already updated in master branch, but not released yet.
+ ;; drms>=0.6.1,<0.7.0
+ (("0.7.0") "0.7.2"))))
(add-before 'install 'writable-compiler
(lambda _
(make-file-writable "sunpy/_compiler.c")))