summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorGuix Together <jgart@dismail.de>2021-08-30 12:40:39 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-08-30 15:32:40 -0400
commitefb756554939e4caa7bb2998b99ab6a95c43a4ec (patch)
tree769961f8412adb0c402c400f54766a7516703670 /gnu/packages/games.scm
parentf48156dc9d52bdef97c3ec6c3462ccdd66f4d6e7 (diff)
gnu: Add go-github-com-anaseto-gruid-tcell.
* gnu/packages/games.scm (go-github-com-anaseto-gruid-tcell): New variable. Co-authored-by: Arun Isaac <arunisaac@systemreboot.net> Co-authored-by: Brice Waegeneire <brice@waegenei.re> Co-authored-by: jgart <jgart@dismail.de> Co-authored-by: Julien Lepiller <julien@lepiller.eu> Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8c299c8b89..93d0105d99 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9403,6 +9403,32 @@ creating grid-based games, but it's also well suited for any grid-based
application.")
(license license:isc)))
+(define-public go-github-com-anaseto-gruid-tcell
+ (package
+ (name "go-github-com-anaseto-gruid-tcell")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/anaseto/gruid-tcell")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "09ajr9mbldjfc44qprplbf8dr8yhlbn2nfnas2z62m9wmklc0qiv"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/anaseto/gruid-tcell"))
+ (propagated-inputs
+ `(("go-github-com-gdamore-tcell-v2" ,go-github-com-gdamore-tcell-v2)
+ ("go-github-com-anaseto-gruid" ,go-github-com-anaseto-gruid)))
+ (home-page "https://github.com/anaseto/gruid-tcell")
+ (synopsis "Gruid driver using the tcell library")
+ (description "The gruid-tcell module provides a Gruid driver for building
+terminal full-window applications.")
+ (license license:isc)))
+
(define-public harmonist
(package
(name "harmonist")