summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-10 02:13:25 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:51 -0400
commitb83ce22d3e580d30112dd2642f4f153368c62540 (patch)
treef281106190e46e6a1397814862f4a528d2ec1790 /gnu/packages/gnome.scm
parente8de035b95193910357272e27481f8993227bc3e (diff)
gnu: gfbgraph: Update to 0.2.5 and enable tests.
* gnu/packages/gnome.scm (gfbgraph): Update to 0.2.5. [tests?]: Delete argument. [configure-flags]: Remove "--enable-gtk-doc" and "--enable-introspection", which are correctly automatically detected. [native-inputs]: Remove autoconf, automake, libtool and which. [inputs]: Remove labels.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm22
1 files changed, 7 insertions, 15 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 69ede24940..53fe1e13ab 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10388,7 +10388,7 @@ compiled.")
(define-public gfbgraph
(package
(name "gfbgraph")
- (version "0.2.4")
+ (version "0.2.5")
(source (origin
(method url-fetch)
(uri (string-append
@@ -10397,26 +10397,18 @@ compiled.")
"gfbgraph-" version ".tar.xz"))
(sha256
(base32
- "0yck7dwvjk16a52nafjpi0a39rxwmg0w833brj45acz76lgkjrb0"))))
+ "1qq3cryhby50xms8zh4s6fmw5p0i7dpg1wvsz5ni78cbyyrq3cww"))))
(build-system glib-or-gtk-build-system)
(arguments
- `(#:tests? #f ; tests appear to require the network
- #:configure-flags '("--disable-static"
- "--enable-gtk-doc"
- "--enable-introspection")))
+ `(#:configure-flags '("--disable-static")))
(native-inputs
(list gobject-introspection
gtk-doc/stable
- pkg-config
- ;; The 0.2.4 ‘release’ tarball isn't bootstrapped.
- autoconf
- automake
- libtool
- which))
+ pkg-config))
(inputs
- `(("json-glib" ,json-glib)
- ("gnome-online-accounts" ,gnome-online-accounts)
- ("rest" ,rest)))
+ (list gnome-online-accounts
+ json-glib
+ rest))
(synopsis "GLib/GObject wrapper for the Facebook API")
(description "This library allows you to use the Facebook API from
GLib/GObject code.")