summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:34:43 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:13 -0500
commit1bc5e65aadb9677313a9b30b0bb67208694710c7 (patch)
tree2544bd6cb45c05d6a8e6995a7bda6646437ab496 /gnu/packages/golang-web.scm
parent213a54e8de6f534a01420335411bd9cfb3220795 (diff)
gnu: go-github-com-andybalholm-cascadia: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-andybalholm-cascadia): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: I185cb923d21685eb5a3952b9990833d3a0709312
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 39a83990ce..3c1abfff2c 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2022 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -35,6 +36,30 @@
;;;
;;; Code:
+(define-public go-github-com-andybalholm-cascadia
+ (package
+ (name "go-github-com-andybalholm-cascadia")
+ (version "1.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/andybalholm/cascadia")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zgc9fjkn7d66cnmgnmalr9lrq4ii1spap95pf2x1hln4pflib5s"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/andybalholm/cascadia"))
+ (native-inputs
+ (list go-golang-org-x-net))
+ (home-page "https://github.com/andybalholm/cascadia/")
+ (synopsis "CSS selectors for HTML")
+ (description "The Cascadia package implements CSS selectors for use with
+the parse trees produced by the html package.")
+ (license license:bsd-2)))
+
(define-public go-github-com-aymerick-douceur
(package
(name "go-github-com-aymerick-douceur")