summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:34:42 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:13 -0500
commit213a54e8de6f534a01420335411bd9cfb3220795 (patch)
tree21fc4d1eb46bdf85cf3da439ee9888d4a3052603 /gnu/packages/golang-web.scm
parentd17d7e6ca1b4517162049dfa7f163b0ab0f737fd (diff)
gnu: go-github-com-aymerick-douceur: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-aymerick-douceur): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: I2e94858736f88333f56d4eb4301acd35e6bb1a33
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 1d61a76268..39a83990ce 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -35,6 +35,32 @@
;;;
;;; Code:
+(define-public go-github-com-aymerick-douceur
+ (package
+ (name "go-github-com-aymerick-douceur")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aymerick/douceur/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1hfysznib0fqbp8vqxpk0xiggpp0ayk2bsddi36vbg6f8zq5f81n"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/aymerick/douceur"))
+ (native-inputs
+ (list go-github-com-andybalholm-cascadia
+ go-github-com-gorilla-css
+ go-github-com-puerkitobio-goquery
+ go-golang-org-x-net))
+ (home-page "https://github.com/aymerick/douceur/")
+ (synopsis "CSS parser and inliner")
+ (description "This package provides a CSS parser and inliner.")
+ (license license:expat)))
+
(define-public go-github-com-gorilla-css
(package
(name "go-github-com-gorilla-css")