summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:34:44 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:14 -0500
commit5dbb2511e77390a65249a7efe9c4badf0ed95d66 (patch)
tree589b463772c96426d8ec035a4eeead959791d18d /gnu/packages/golang-web.scm
parent1bc5e65aadb9677313a9b30b0bb67208694710c7 (diff)
gnu: go-github-com-puerkitobio-goquery: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-puerkitobio-goquery): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: Ic0415a8b280ebd12086a5976c9765c1dbbf50bd2
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 3c1abfff2c..8d8b4fb85c 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2,6 +2,8 @@
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2022 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
@@ -131,6 +133,30 @@ the parse trees produced by the html package.")
incoming requests with their respective handler.")
(license license:bsd-3)))
+(define-public go-github-com-puerkitobio-goquery
+ (package
+ (name "go-github-com-puerkitobio-goquery")
+ (version "1.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/PuerkitoBio/goquery")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gh1d99l5xc9hvwa4j40pfq3y9vfyq52mnrz6bf1kw2r2zr2gbcc"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/PuerkitoBio/goquery"))
+ (propagated-inputs
+ (list go-github-com-andybalholm-cascadia go-golang-org-x-net))
+ (home-page "https://github.com/PuerkitoBio/goquery")
+ (synopsis "Features similar to jQuery to the Go language")
+ (description "@code{goquery} brings a syntax and a set of features similar
+to jQuery to the Go language.")
+ (license license:bsd-3)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar