summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-01-17 22:46:31 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-14 22:59:14 +0000
commit51f8d606658bd3813dc0a395c5fa5bb937f35559 (patch)
treec739ec4b54aae1e8b6b15d1b6d0621da78c58bfa /gnu/packages/golang-xyz.scm
parent40cc2ca588607f976f0adc094b91a886ef0044f6 (diff)
gnu: Add go-github-com-coreos-go-systemd-machine1.
* gnu/packages/golang.scm (go-github-com-coreos-go-systemd-machine1): New variable. Change-Id: I2d9340a2b70dd68e24e4a88bdcd1f4c289100c6d Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 909442a762..6b18d33ed1 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -284,6 +284,20 @@ service, journald.")))
(description "Go bindings to systemd for integration with the systemd
logind API.")))
+(define-public go-github-com-coreos-go-systemd-machine1
+ (package
+ (inherit go-github-com-coreos-go-systemd-activation)
+ (name "go-github-com-coreos-go-systemd-machine1")
+ (arguments
+ '(#:tests? #f ;Tests require D-Bus daemon running.
+ #:import-path "github.com/coreos/go-systemd/machine1"
+ #:unpack-path "github.com/coreos/go-systemd"))
+ (native-inputs (list go-github-com-godbus-dbus))
+ (home-page "https://github.com/coreos/go-systemd")
+ (synopsis "Go bindings to systemd for registering machines/containers")
+ (description "Go bindings to systemd for registering
+machines/containers.")))
+
(define-public go-github-com-cyberdelia-go-metrics-graphite
(package
(name "go-github-com-cyberdelia-go-metrics-graphite")