summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-01-17 22:34:12 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-14 22:59:13 +0000
commitcfeec48158d2a52ce4fc9d560075ffba1f3b6822 (patch)
treed73c2636a8e8e0de7fee93d9f9bb51f1bdfbb341 /gnu/packages/golang-xyz.scm
parent30afb17152462e180b92b06829ab85d0a2d337cf (diff)
gnu: Add go-github-com-coreos-go-systemd-dbus.
* gnu/packages/golang.scm (go-github-com-coreos-go-systemd-dbus): New variable. Change-Id: Ib50ff86ec7c03fd8b5e732dc9b3ec5e4196d8d3b Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 210d9d72fa..c968b0018b 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -243,6 +243,20 @@ using socket activation from Go.")
(description "Go bindings to systemd for notifying the daemon of service
status changes")))
+(define-public go-github-com-coreos-go-systemd-dbus
+ (package
+ (inherit go-github-com-coreos-go-systemd-activation)
+ (name "go-github-com-coreos-go-systemd-dbus")
+ (arguments
+ '(#:tests? #f ;Tests require D-Bus daemon running.
+ #:import-path "github.com/coreos/go-systemd/dbus"
+ #:unpack-path "github.com/coreos/go-systemd"))
+ (native-inputs (list go-github-com-godbus-dbus))
+ (home-page "https://github.com/coreos/go-systemd")
+ (synopsis "Go bindings to systemd for managing services")
+ (description "Go bindings to systemd for starting/stopping/inspecting
+running services and units.")))
+
(define-public go-github-com-cyberdelia-go-metrics-graphite
(package
(name "go-github-com-cyberdelia-go-metrics-graphite")