summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-09 21:34:43 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 16:35:20 +0100
commitd4032419ddc4caca20f9ff58cb44994f0d5cba8f (patch)
tree680bbd78bc1ae9278a12e3ce4f676edae581b130 /gnu/packages/golang-xyz.scm
parentcd557e2d1c83839dd587016279900d31f053efc8 (diff)
gnu: go-github-com-gobwas-glob: Move to golang-xyz.
* gnu/packages/syncthing.scm (go-github-com-gobwas-glob): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/textutils.scm: Remove (gnu packages syncthing) module. Change-Id: I131830e6edcdb666aeb3cd9bbdf6982df938ccd4
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 9968bc9516..71303be53d 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1202,6 +1202,30 @@ interfaces to back that API. Packages in the Go ecosystem can depend on it,
while callers can implement logging with whatever backend is appropriate.")
(license license:asl2.0)))
+(define-public go-github-com-gobwas-glob
+ (package
+ (name "go-github-com-gobwas-glob")
+ (version "0.2.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gobwas/glob")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0jxk1x806zn5x86342s72dq2qy64ksb3zrvrlgir2avjhwb18n6z"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/gobwas/glob"))
+ (home-page "https://github.com/gobwas/glob")
+ (synopsis "Go globbing library")
+ (description
+ "This package provides a Go implementation of globs.")
+ (license license:expat)))
+
(define-public go-github-com-hashicorp-errwrap
(package
(name "go-github-com-hashicorp-errwrap")