summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-09-01 20:58:12 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-04 22:46:06 -0400
commit91ae69603239711d0b0e959e8eaaae56ca8fe55c (patch)
tree09014f1d1b10baba3f39be3d9c46a0cedc1be41c /gnu/packages/golang.scm
parentc7a881fc5e1d1280506eb29a1f186a67da8fefdd (diff)
gnu: Add go-github-com-bmizerany-perks-quantile.
* gnu/packages/golang.scm (go-github-com-bmizerany-perks-quantile): New variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 224b47f993..5756ce582d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9177,6 +9177,30 @@ the library more lightweight.")
matching and globbing with support for \"doublestar\" patterns.")
(license license:expat)))
+(define-public go-github-com-bmizerany-perks-quantile
+ (package
+ (name "go-github-com-bmizerany-perks-quantile")
+ (version "0.0.0-20230307044200-03f9df79da1e")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bmizerany/perks")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1f2a99v3618bz2mf61iwhdjm3xi1gam6v4apqgcrz71gj7ba9943"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:unpack-path "github.com/bmizerany/perks"
+ #:import-path "github.com/bmizerany/perks/quantile"))
+ (home-page "https://github.com/bmizerany/perks")
+ (synopsis "Library for computing quantiles")
+ (description
+ "Perks contains the Go package @code{quantile} that computes approximate
+quantiles over an unbounded data stream within low memory and CPU bounds.")
+ (license license:bsd-2)))
+
(define-public go-github-com-dlclark-regexp2
(package
(name "go-github-com-dlclark-regexp2")