summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-06-05 21:52:14 +0800
committerLudovic Courtès <ludo@gnu.org>2023-07-01 23:38:26 +0200
commit9e9d73333dbe5203c8844b1bebac32e805ad8bdd (patch)
treeaca4095b3a550935210499822ea353b86ce62813 /gnu/packages/golang.scm
parentf69e7eaf737200d498a48c21406ca81bc4aa442b (diff)
gnu: Add go-gopkg-in-square-go-jose-v2.
* gnu/packages/golang.scm (go-gopkg-in-square-go-jose-v2): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a3794f9474..48b8001027 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3213,6 +3213,35 @@ and anniversaries.")
"This is the official AWS SDK for the Go programming language.")
(license license:asl2.0)))
+(define-public go-gopkg-in-square-go-jose-v2
+ (package
+ (name "go-gopkg-in-square-go-jose-v2")
+ (version "2.6.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/square/go-jose")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1b1nhqxfmhzwrfk7pkvp2w3z3d0pf5ir00vizmy2d4xdbnldn70r"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "gopkg.in/square/go-jose.v2"))
+ (propagated-inputs
+ (list go-golang-org-x-crypto))
+ (native-inputs
+ (list go-github-com-google-go-cmp-cmp
+ go-github-com-stretchr-testify))
+ (home-page "https://gopkg.in/square/go-jose.v2")
+ (synopsis "Implementation of JOSE standards (JWE, JWS, JWT) in Go")
+ (description
+ "This package aims to provide an implementation of the Javascript Object
+Signing and Encryption set of standards. This includes support for JSON Web
+Encryption, JSON Web Signature, and JSON Web Token standards.")
+ (license license:asl2.0)))
+
(define-public go-gopkg.in-tomb.v2
(let ((commit "d5d1b5820637886def9eef33e03a27a9f166942c")
(revision "0"))