summaryrefslogtreecommitdiff
path: root/gnu/packages/ipfs.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-17 22:34:36 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-17 22:55:55 +0100
commit4678b09f440af89646760d7fea0ea7a924817fbd (patch)
treec70ccb89b9e848155dc0d68bb4187b45009b75aa /gnu/packages/ipfs.scm
parentdbd078a5c972f60a2d05709a2fe2f5fc417e396d (diff)
gnu: Add go-github-com-ipfs-go-ipfs-delay.
* gnu/packages/ipfs.scm (go-github-com-ipfs-go-ipfs-delay): New variable. Change-Id: I4938d20d9916d9573e8cb01b9e93ba710c7c5b3c
Diffstat (limited to 'gnu/packages/ipfs.scm')
-rw-r--r--gnu/packages/ipfs.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 505003229c..f93a708355 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2020, 2021, 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2023, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -158,6 +159,30 @@ that are shared between @command{go-ipfs/commands} and its rewrite
@command{go-ipfs-cmds}.")
(license license:expat))))
+(define-public go-github-com-ipfs-go-ipfs-delay
+ (package
+ (name "go-github-com-ipfs-go-ipfs-delay")
+ (version "0.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-ipfs-delay")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0a5acj622sk1hibnh893mya4h86nsy1dan0wlh9q444c04iqpviw"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/ipfs/go-ipfs-delay"))
+ (home-page "https://github.com/ipfs/go-ipfs-delay")
+ (synopsis "Configurable delays to other objects")
+ (description
+ "This package implements a threadsafe configurable delays to other
+objects.")
+ (license license:expat)))
+
(define-public go-github-com-ipfs-go-detect-race
(package
(name "go-github-com-ipfs-go-detect-race")