summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2023-05-17 15:16:18 +0000
committerLudovic Courtès <ludo@gnu.org>2023-08-17 17:39:32 +0200
commitc1090dd4d6f65aa39a66f1adc4c2b70c96d31abd (patch)
tree4c9987bcf1bdd7ed42a7f791f53fcddb9311f9df /gnu/packages/patches
parent7af5597e21ef6d7f19554c3acbe75f108f663421 (diff)
gnu: bloomberg-bde: Update to 3.118.0.1.
* gnu/packages/cpp.scm (bloomberg-bde): Update to 3.118.0.1. [source](origin): Update test deletion list. [arguments]<#:configure-flags>: Update from C++17 to C++20. [supported-systems]: Only support x86_64-linux. * gnu/packages/patches/bloomberg-bde-cmake-module-path.patch: Rebase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/bloomberg-bde-cmake-module-path.patch14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/patches/bloomberg-bde-cmake-module-path.patch b/gnu/packages/patches/bloomberg-bde-cmake-module-path.patch
index b08ca5eac0..7743863cf8 100644
--- a/gnu/packages/patches/bloomberg-bde-cmake-module-path.patch
+++ b/gnu/packages/patches/bloomberg-bde-cmake-module-path.patch
@@ -4,13 +4,11 @@ locating the bloomberg-bde-tools CMake modules.
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -1,8 +1,6 @@
- cmake_minimum_required(VERSION 3.15)
+@@ -14,6 +14,7 @@ else()
+ if (NOT CMAKE_MODULE_PATH)
+ message(FATAL "Please specify path to BDE cmake modules.")
+ endif()
++ string(REPLACE ":" "cmake/;" CMAKE_MODULE_PATH "$ENV{CMAKE_PREFIX_PATH}cmake/")
--if (NOT CMAKE_MODULE_PATH)
-- message(FATAL "Please specify path to BDE cmake modules.")
--endif()
-+string(REPLACE ":" "cmake/;" CMAKE_MODULE_PATH "$ENV{CMAKE_PREFIX_PATH}cmake/")
-
- get_filename_component(repoName ${CMAKE_CURRENT_LIST_DIR} NAME)
+ include(bde_workspace)