summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-04-18 00:45:36 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-04-18 00:45:36 -0400
commita5c4b50c36846c5ced7978a176a5de6c6a142b18 (patch)
treea772e23a1ddd6a3c6e233bd6207eb80aae1a51fd /gnu/packages/python-web.scm
parent3e8d608dac2eb9f387431bd8976f78de9ea7a701 (diff)
gnu: python-google-auth: Update to 2.17.3.
* gnu/packages/python-web.scm (python-google-auth): Update to 2.17.3. [native-inputs]: Add python-mock.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 534367c789..91a045c563 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7298,13 +7298,13 @@ of the CRC32C hashing algorithm.")
(define-public python-google-auth
(package
(name "python-google-auth")
- (version "2.6.6")
+ (version "2.17.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "google-auth" version))
(sha256
- (base32 "04ikassansqkkw4pa98in7q9r4z001m6bi2r3ssxwwrb0f79790v"))))
+ (base32 "1z2f0vj374rscvlivhvf9xxjlg4lng4mgpqnygfhy4wbqlmiwcff"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -7322,6 +7322,7 @@ of the CRC32C hashing algorithm.")
(native-inputs
(list python-flask
python-freezegun
+ python-mock
python-oauth2client
python-pyopenssl
python-pytest