summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorJohn Doe <dftxbs3e@free.fr>2020-12-27 23:26:49 +0100
committerEfraim Flashner <efraim@flashner.co.il>2020-12-28 13:21:14 +0200
commit57bba2ee54fa67de66fd76e66868ac863fa5056a (patch)
tree8c991c7f63100b6973f60e615eec4843151a986a /gnu/packages/python-xyz.scm
parent51ad28ae71fd4b3d724003f334c0bbd15f60ca65 (diff)
gnu: Add python-bitstring.
* gnu/packages/python-xyz.scm (python-bitstring): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ccd597dd0d..069fe91079 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23300,3 +23300,23 @@ environment.")
(description "QDarkStyle is the most complete dark stylesheet for Python and
Qt applications.")
(license license:expat)))
+
+(define-public python-bitstring
+ (package
+ (name "python-bitstring")
+ (version "3.1.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "bitstring" version))
+ (sha256
+ (base32
+ "0jl6192dwrlm5ybkbh7ywmyaymrc3cmz9y07nm7qdli9n9rfpwzx"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/scott-griffiths/bitstring")
+ (synopsis
+ "Simple construction, analysis and modification of binary data")
+ (description
+ "Bitstring is a library for simple construction, analysis and modification
+ of binary data.")
+ (license license:expat)))