summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-11 13:45:51 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-13 00:08:54 +0100
commit99a29b4933144599c29bd54a0eb654b20cbe6500 (patch)
treebb3dbf75c07744b592febe78f430ce165dd71148 /gnu/packages/python-xyz.scm
parent0fcba8b01c23af756dba5f863db8712d6f840f36 (diff)
gnu: python-apispec: Update to 6.0.2.
* gnu/packages/python-xyz.scm (python-apispec): Update to 6.0.2. [build-system]: Use pyproject-build-system. [arguments]: Disable test through test-flags, not by replacing the 'check phase. [propagated-inputs]: Remove python-pyyaml; add python-packaging. [native-inputs]: Add python-flake8, python-flake8-bugbear, python-mypy, python-pre-commit, and python-pyyaml.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm39
1 files changed, 21 insertions, 18 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2d013054ec..0ddb91cf79 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21012,33 +21012,36 @@ datatypes to and from native Python datatypes.")
(define-public python-apispec
(package
(name "python-apispec")
- (version "4.0.0")
+ (version "6.0.2")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "apispec" version))
- (sha256
+ (method url-fetch)
+ (uri (pypi-uri "apispec" version))
+ (sha256
(base32
- "12n4w5zkn4drcn8izq68vmixmqvz6abviqkdn4ip0kaax3jjh3in"))))
- (build-system python-build-system)
+ "11vqxwdxmm7qmyhdbxk4gnx37nbzmn266ah92gi4pvzd76vq0vg7"))))
+ (build-system pyproject-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "pytest" "-vv"
- ;; Disable validation tests since they require
- ;; the optional 'prance' library which is not
- ;; yet in Guix.
- "-k" "not openapi_tools_validate"))))))
+ (list
+ ;; Disable validation tests since they require
+ ;; the optional 'prance' library which is not
+ ;; yet in Guix.
+ #:test-flags '(list "-k" "not openapi_tools_validate")))
(propagated-inputs
- (list python-pyyaml))
+ (list python-packaging))
(native-inputs
- (list python-pytest python-marshmallow))
+ (list python-flake8
+ python-flake8-bugbear
+ python-marshmallow
+ python-mypy
+ python-pre-commit
+ python-pytest
+ python-pyyaml))
(home-page "https://github.com/marshmallow-code/apispec")
(synopsis "Swagger/OpenAPI specification generator")
(description "@code{python-apispec} is a pluggable API specification
- generator. It currently supports the OpenAPI specification, formerly known
- as Swagger.")
+generator. It currently supports the OpenAPI specification, formerly known as
+Swagger.")
(license license:expat)))
(define-public python-apispec-webframeworks