summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-10-08 14:10:50 +0200
committerLudovic Courtès <ludo@gnu.org>2020-10-10 22:43:20 +0200
commitd31277e7b272f366bb872b34291d7fdb658ed12c (patch)
tree158060f746e75c33905d842233e4b6b05b37976f /gnu/packages/python-xyz.scm
parentc9a99803dd392969b8dc7f0386c0b99ca40073c9 (diff)
gnu: Add python-nestedtext.
* gnu/packages/python-xyz.scm (python-nestedtext): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 37f911b512..25eaf4a625 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22190,3 +22190,31 @@ are plain text, reStructuredText and HTML.")
a console. It provides a collection of ‘print’ functions that allow you to simply and
cleanly print different types of messages.")
(license license:gpl3+)))
+
+(define-public python-nestedtext
+ (package
+ (name "python-nestedtext")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "nestedtext" version))
+ (sha256
+ (base32
+ "0xjx863n7yd1xmkwhy48lhmqrmlzgbx3civhk386hvrzyq4sx148"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; PyPI tarball lacks tests
+ (propagated-inputs
+ `(("python-inform" ,python-inform)))
+ (home-page "https://nestedtext.org")
+ (synopsis "Human readable and writable data interchange format")
+ (description
+ "NestedText is a file format for holding data that is to be entered, edited, or
+viewed by people. It allows data to be organized into a nested collection of
+dictionaries, lists, and strings. In this way it is similar to JSON and YAML, but
+without the complexity and risk of YAML and without the syntatic clutter of JSON.
+NestedText is both simple and natural. Only a small number of concepts and rules must
+be kept in mind when creating it. It is easily created, modified, or viewed with
+a text editor and easily understood and used by both programmers and non-programmers.")
+ (license license:expat))) ; MIT license