summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-02-17 14:30:01 -0500
committerLeo Famulari <leo@famulari.name>2023-02-17 14:49:13 -0500
commit861d6fa92c465920e65db47ee4fac531156500ec (patch)
treed3cead1bcff4bcf939c08b54329f8cd22b655228 /gnu/packages/qt.scm
parentabe7afb17ced298743f3eca2fa156d480fdd038d (diff)
gnu: Remove QtWebKit.
This fixes <https://issues.guix.gnu.org/53289>. * gnu/packages/qt.scm (qtwebkit): Remove variable. * gnu/packages/patches/qtwebkit-fix-building-with-bison-3.7.patch, gnu/packages/patches/qtwebkit-fix-building-with-glib-2.68.patch, gnu/packages/patches/qtwebkit-fix-building-with-icu-68.patch, gnu/packages/patches/qtwebkit-fix-building-with-python-3.9.patch, gnu/packages/patches/qtwebkit-pbutils-include.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. * gnu/packages/education.scm (openboard): Adjust code comment.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm83
1 files changed, 0 insertions, 83 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index cad07ea19d..b32a78085d 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -3803,89 +3803,6 @@ different kinds of sliders, and much more.")
;; textengines/mathml/qwt_mml_document.{cpp,h} is dual LGPL2.1/GPL3 (either).
license:lgpl2.1 license:gpl3))))
-(define-public qtwebkit
- (package
- (name "qtwebkit")
- (version "5.212.0-alpha4")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/annulen/webkit/releases/download/"
- "qtwebkit-" version "/qtwebkit-" version ".tar.xz"))
- (sha256
- (base32
- "1rm9sjkabxna67dl7myx9d9vpdyfxfdhrk9w7b94srkkjbd2d8cw"))
- (patches (search-patches "qtwebkit-pbutils-include.patch"
- "qtwebkit-fix-building-with-bison-3.7.patch"
- "qtwebkit-fix-building-with-glib-2.68.patch"
- "qtwebkit-fix-building-with-icu-68.patch"
- "qtwebkit-fix-building-with-python-3.9.patch"))))
- (build-system cmake-build-system)
- (native-inputs
- (list perl
- python
- ruby
- bison
- flex
- gperf
- pkg-config))
- (inputs
- `(("icu" ,icu4c)
- ("glib" ,glib)
- ("gst-plugins-base" ,gst-plugins-base)
- ("libjpeg" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("libwebp" ,libwebp)
- ("sqlite" ,sqlite)
- ("fontconfig" ,fontconfig)
- ("libxrender" ,libxrender)
- ("qtbase" ,qtbase-5)
- ("qtdeclarative-5" ,qtdeclarative-5)
- ("qtlocation" ,qtlocation)
- ("qtmultimedia-5" ,qtmultimedia-5)
- ("qtsensors" ,qtsensors)
- ("qtwebchannel-5" ,qtwebchannel-5)
- ("libxml2" ,libxml2)
- ("libxslt" ,libxslt)
- ("libx11" ,libx11)
- ("libxcomposite" ,libxcomposite)))
- (arguments
- `(#:tests? #f ; no apparent tests; it might be necessary to set
- ; ENABLE_API_TESTS, see CMakeLists.txt
-
- ;; Parallel builds fail due to a race condition:
- ;; <https://bugs.gnu.org/34062>.
- #:parallel-build? #f
-
- #:configure-flags (list ;"-DENABLE_API_TESTS=TRUE"
- "-DPORT=Qt"
- "-DUSE_LIBHYPHEN=OFF"
- "-DUSE_SYSTEM_MALLOC=ON"
- ;; XXX: relative dir installs to build dir?
- (string-append "-DECM_MKSPECS_INSTALL_DIR="
- %output "/lib/qt5/mkspecs/modules")
- ;; Sacrifice a little speed in order to link
- ;; libraries and test executables in a
- ;; reasonable amount of memory.
- "-DCMAKE_SHARED_LINKER_FLAGS=-Wl,--no-keep-memory"
- "-DCMAKE_EXE_LINKER_FLAGS=-Wl,--no-keep-memory")))
- (home-page "https://www.webkit.org")
- (synopsis "Web browser engine and classes to render and interact with web
-content")
- (description "QtWebKit provides a Web browser engine that makes it easy to
-embed content from the World Wide Web into your Qt application. At the same
-time Web content can be enhanced with native controls.")
- ;; Building QtWebKit takes around 13 hours on an AArch64 machine. Give some
- ;; room for slower or busy hardware.
- (properties '((timeout . 64800))) ;18 hours
-
- ;; XXX: This consumes too much RAM to successfully build on AArch64 (e.g.,
- ;; SoftIron OverDrive with 8 GiB of RAM), so instead of wasting resources,
- ;; disable it on non-Intel platforms.
- (supported-systems '("x86_64-linux" "i686-linux"))
-
- (license license:lgpl2.1+)))
-
(define-public dotherside
(package
(name "dotherside")