summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2022-08-13 16:50:53 +0530
committerArun Isaac <arunisaac@systemreboot.net>2022-08-13 17:17:59 +0530
commit93d8523487ee869dc4950fdab06659f6dc919ec2 (patch)
treec9d0dec1aaeb7b9d70c98a3ff588a0a678717824 /gnu/packages/web.scm
parentff564de64cdd4bd3d6d578b0beeefef1d062e68f (diff)
gnu: kiwix-desktop: Update to 2.2.2.
* gnu/packages/web.scm (kiwix-desktop): Update to 2.2.2. [arguments]: Delete enable-print-support and substitute-source phases. Use search-input-file. Do not return #t from phases. [native-inputs]: Remove labels.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm28
1 files changed, 7 insertions, 21 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 8c7df5af1e..6f506dc490 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -8032,7 +8032,7 @@ It contains the code shared by all Kiwix ports.")
(define-public kiwix-desktop
(package
(name "kiwix-desktop")
- (version "2.0.5")
+ (version "2.2.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -8041,7 +8041,7 @@ It contains the code shared by all Kiwix ports.")
".tar.gz"))
(sha256
(base32
- "1a9h4qmh6fkfscyp6lax0ri07dvvzw2wp4kr1sm86n0bdk3cwwha"))))
+ "0ani12d91azcwwys499848ws7rx0m7c23nalcm5fanjak76bg6n6"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -8051,28 +8051,14 @@ It contains the code shared by all Kiwix ports.")
(invoke "qmake"
(string-append "PREFIX="
(assoc-ref outputs "out")))))
- (add-before 'configure 'enable-print-support
- (lambda _
- (substitute* "kiwix-desktop.pro"
- (("webenginewidgets") "webenginewidgets printsupport"))
- #t))
- (add-before 'configure 'substitute-source
- ;; Looks like .pro file is missing a feature.
- ;; See https://github.com/kiwix/kiwix-desktop/issues/556.
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "kiwix-desktop.pro"
- (("webenginewidgets" all) (string-append all " printsupport")))
- #t))
(add-after 'install 'wrap-qt-process-path
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin/kiwix-desktop"))
- (qt-process-path (string-append
- (assoc-ref inputs "qtwebengine-5")
- "/lib/qt5/libexec/QtWebEngineProcess")))
+ (qt-process-path (search-input-file
+ inputs "/lib/qt5/libexec/QtWebEngineProcess")))
(wrap-program bin
- `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))
- #t))))))
+ `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))))))))
(inputs
(list curl
icu4c
@@ -8088,8 +8074,8 @@ It contains the code shared by all Kiwix ports.")
zlib
`(,zstd "lib")))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("qmake" ,qtbase-5)))
+ (list pkg-config
+ qtbase-5))
(home-page "https://wiki.kiwix.org/wiki/Software")
(synopsis "Viewer and manager of ZIM files")
(description "Kiwix Desktop allows you to enjoy a lot of different content