summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-03-21 16:05:23 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-19 20:12:21 -0400
commit05b22726ea34b7e934390d4fb794e80c189fb872 (patch)
treea49f8b95cb56ac6f65e6ea4f23871fd77d333f11 /gnu/packages
parentd89e642e8443c0c9fa929207bbda19a4304ef554 (diff)
gnu: usbutils: Use G-Expressions.
* gnu/packages/linux.scm (usbutils): Use G-Expressions. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm33
1 files changed, 16 insertions, 17 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 03d77014ac..c6fce0992f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2379,23 +2379,22 @@ slabtop, tload, top, vmstat, w, watch and sysctl.")
(build-system gnu-build-system)
(outputs (list "out" "python"))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'bootstrap 'patch-bootstrap-scripts
- (lambda _
- (substitute* "usbhid-dump/bootstrap"
- (("/bin/sh") (which "sh")))))
- (add-after 'install 'separate-python-output
- ;; Separating one Python script shaves more than 106 MiB from :out.
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (out:python (assoc-ref outputs "python")))
- (for-each (lambda (file)
- (let ((old (string-append out "/" file))
- (new (string-append out:python "/" file)))
- (mkdir-p (dirname new))
- (rename-file old new)))
- (list "bin/lsusb.py"))))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'bootstrap 'patch-bootstrap-scripts
+ (lambda _
+ (substitute* "usbhid-dump/bootstrap"
+ (("/bin/sh") (which "sh")))))
+ (add-after 'install 'separate-python-output
+ ;; Separating one Python script shaves more than 106 MiB from :out.
+ (lambda _
+ (for-each (lambda (file)
+ (let ((old (string-append #$output "/" file))
+ (new (string-append #$output:python "/" file)))
+ (mkdir-p (dirname new))
+ (rename-file old new)))
+ (list "bin/lsusb.py")))))))
(inputs
(list eudev libusb python))
(native-inputs