summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 15:06:36 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:32 +0200
commit159cc006690ad38e94c584c04904a0b85758811f (patch)
tree811c4dacfd1bc066739bcea76cb46e6d24baa671 /gnu/packages
parentd822f3aaace66e0a8c2088f013091fef345048c9 (diff)
gnu: Add texlive-nodetree.
* gnu/packages/tex.scm (texlive-nodetree): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 68a5d92199..b6ab8b161f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6449,6 +6449,27 @@ collect an argument verbatim to either typeset or write it into a file. The
used to write the verbatim text to a file.")
(license license:lppl1.3+)))
+(define-public texlive-nodetree
+ (package
+ (name "texlive-nodetree")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/luatex/nodetree/"
+ "source/luatex/nodetree/"
+ "tex/luatex/nodetree/")
+ (base32
+ "00lj7wykgc2r5pgijm9lxjrghq8bsx6whanzvsxcwf639mzv3528")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/nodetree")
+ (synopsis "Visualize node lists in a tree view")
+ (description
+ "@code{nodetree} is a development package that visualizes the structure
+of node lists. It uses a similar visual representation for node lists as the
+UNIX @command{tree} command for a folder structure.")
+ (license license:lppl1.3+)))
+
(define-public texlive-noto
(package
(name "texlive-noto")