summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-21 15:16:43 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-22 12:35:18 +0200
commit6cd438c4c2beb016a821143cdfdd12892aa9fd5f (patch)
treecaf25886dc98103f723bd93cec84d8a95ca96aac /gnu/packages
parent02deb211379cd987a7fa0a3ee0171a84b310dac0 (diff)
gnu: openssl: Skip time-dependent test.
Fixes <https://issues.guix.gnu.org/56137>. Reported by phodina <phodina@protonmail.com>. * gnu/packages/tls.scm (openssl)[arguments]: Replace the 'check' phase; this applies to both 1.1.1n and 3.0.3.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tls.scm23
1 files changed, 14 insertions, 9 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index bd1f010d0a..86dc249984 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -422,15 +422,20 @@ OpenSSL for TARGET."
#$(target->openssl-target
(%current-target-system))))))
#~())
- ;; This test seems to be dependant on kernel features.
- ;; https://github.com/openssl/openssl/issues/12242
- #$@(if (or (target-arm?)
- (target-riscv64?))
- #~((replace 'check
- (lambda* (#:key tests? test-target #:allow-other-keys)
- (when tests?
- (invoke "make" "TESTS=-test_afalg" test-target)))))
- #~())
+ (replace 'check
+ (lambda* (#:key tests? test-target #:allow-other-keys)
+ (when tests?
+ ;; 'test_ssl_new.t' in 1.1.1n and 3.0.3 fails due to an expired
+ ;; certificate:
+ ;; <https://github.com/openssl/openssl/issues/18441>.
+ ;; Skip it.
+ ;;
+ ;; 'test_afalg' seems to be dependent on kernel features:
+ ;; <https://github.com/openssl/openssl/issues/12242>.
+ (invoke "make" test-target
+ #$(if (or (target-arm?) (target-riscv64?))
+ "TESTS=-test_afalg -tls_ssl_new"
+ "TESTS=-test_ssl_new")))))
(replace 'configure
(lambda* (#:key configure-flags #:allow-other-keys)
(let* ((out #$output)