summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:50:02 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:19 +0200
commitaffd215764d0b7a9aa2d6ad7908478bbe64c3d3c (patch)
tree949cf686efd01bb85fbee99647e88765e67ca858 /gnu/packages
parentdf7913fbe0a3280c0250fe4622a102d0edfb6a78 (diff)
gnu: Add texlive-luacas.
* gnu/packages/tex.scm (texlive-luacas): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 421d158766..6dfa589646 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16304,6 +16304,39 @@ while they are read. With @code{luaaddplot} it is no longer necessary to
pre-process data files generated by measuring devices with external scripts.")
(license license:lppl1.3+)))
+(define-public texlive-luacas
+ (package
+ (name "texlive-luacas")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/luacas/"
+ "tex/lualatex/luacas/_lib/"
+ "tex/lualatex/luacas/algebra/"
+ "tex/lualatex/luacas/calculus/"
+ "tex/lualatex/luacas/core/binaryoperation/"
+ "tex/lualatex/luacas/test/calculus/"
+ "tex/lualatex/luacas/test/expressions/"
+ "tex/lualatex/luacas/test/polynomials/"
+ "tex/lualatex/luacas/test/rings/")
+ (base32
+ "03z33kphj85y5w0sdgrgsh1pajbxwjiiir0s972cjn3f8ns6xw9x")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/luacas")
+ (synopsis "Computer algebra system for users of LuaLaTeX")
+ (description
+ "This package provides a portable computer algebra system capable of
+symbolic computation, written entirely in Lua, designed for use in LuaLaTeX.
+Its features are: arbitrary-precision integer and rational arithmetic,
+factoring of univariate polynomials over the rationals and finite fields,
+number theoretic algorithms, symbolic differentiation and integration, and
+more. The target audience for this package are mathematics students,
+instructors, and professionals who would like some ability to perform basic
+symbolic computations within LaTeX without the need for laborious and
+technical setup.")
+ (license license:lppl1.3c)))
+
(define-public texlive-babel-czech
(package
(name "texlive-babel-czech")