summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-02-19 01:11:10 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-21 20:16:22 +0000
commitf7c55f54b6e7e0e432119f67b1ef5dac82f016b5 (patch)
treeb34b524cb1b07e8a9f876f684f856526b332c991 /gnu/packages
parenta78a1fc3f0908eea583d2b29a746094d69853443 (diff)
gnu: node-serialport-parser-inter-byte-timeout: Move in order.
* gnu/packages/node-xyz.scm (node-serialport-parser-inter-byte-timeout): Move package in alphabetical order. Change-Id: Ice71f75c197b6d8f0e0c0c5b5bdb03ebf1d1d4cb Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/node-xyz.scm44
1 files changed, 22 insertions, 22 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index e432f97ae8..b49a19372b 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -1314,6 +1314,28 @@ Parsers are used to take raw binary data and transform them into usable
messages. This package provides @code{Delimiter}, a parser that emits data
each time a specified byte sequence is received.")))
+(define-public node-serialport-parser-inter-byte-timeout
+ (package
+ (inherit node-serialport)
+ (name "node-serialport-parser-inter-byte-timeout")
+ (version "9.2.4")
+ (inputs `())
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda args
+ (chdir "packages/parser-inter-byte-timeout"))))
+ #:tests? #f))
+ (synopsis "Node SerialPort parser to detect pauses in data")
+ (description "Node SerialPort is a modular suite of Node.js packages for
+accessing serial ports. The Guix package @code{node-serialport} provides the
+recommended high-level interface.
+
+Parsers are used to take raw binary data and transform them into usable
+messages. This package provides @code{InterByteTimeout}, a parser that emits
+data if there is a pause between packets for the specified amount of time.")))
+
(define-public node-serialport-parser-readline
(package
(inherit node-serialport)
@@ -1382,28 +1404,6 @@ Parsers are used to take raw binary data and transform them into usable
messages. This package provides @code{Regex}, a parser that uses a regular
expression to split the incoming text.")))
-(define-public node-serialport-parser-inter-byte-timeout
- (package
- (inherit node-serialport)
- (name "node-serialport-parser-inter-byte-timeout")
- (version "9.2.4")
- (inputs `())
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'chdir
- (lambda args
- (chdir "packages/parser-inter-byte-timeout"))))
- #:tests? #f))
- (synopsis "Node SerialPort parser to detect pauses in data")
- (description "Node SerialPort is a modular suite of Node.js packages for
-accessing serial ports. The Guix package @code{node-serialport} provides the
-recommended high-level interface.
-
-Parsers are used to take raw binary data and transform them into usable
-messages. This package provides @code{InterByteTimeout}, a parser that emits
-data if there is a pause between packets for the specified amount of time.")))
-
(define-public node-serialport-stream
(package
(inherit node-serialport)