summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/node-xyz.scm44
1 files changed, 22 insertions, 22 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index e432f97ae8..b49a19372b 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -1314,6 +1314,28 @@ Parsers are used to take raw binary data and transform them into usable
messages. This package provides @code{Delimiter}, a parser that emits data
each time a specified byte sequence is received.")))
+(define-public node-serialport-parser-inter-byte-timeout
+ (package
+ (inherit node-serialport)
+ (name "node-serialport-parser-inter-byte-timeout")
+ (version "9.2.4")
+ (inputs `())
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda args
+ (chdir "packages/parser-inter-byte-timeout"))))
+ #:tests? #f))
+ (synopsis "Node SerialPort parser to detect pauses in data")
+ (description "Node SerialPort is a modular suite of Node.js packages for
+accessing serial ports. The Guix package @code{node-serialport} provides the
+recommended high-level interface.
+
+Parsers are used to take raw binary data and transform them into usable
+messages. This package provides @code{InterByteTimeout}, a parser that emits
+data if there is a pause between packets for the specified amount of time.")))
+
(define-public node-serialport-parser-readline
(package
(inherit node-serialport)
@@ -1382,28 +1404,6 @@ Parsers are used to take raw binary data and transform them into usable
messages. This package provides @code{Regex}, a parser that uses a regular
expression to split the incoming text.")))
-(define-public node-serialport-parser-inter-byte-timeout
- (package
- (inherit node-serialport)
- (name "node-serialport-parser-inter-byte-timeout")
- (version "9.2.4")
- (inputs `())
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'chdir
- (lambda args
- (chdir "packages/parser-inter-byte-timeout"))))
- #:tests? #f))
- (synopsis "Node SerialPort parser to detect pauses in data")
- (description "Node SerialPort is a modular suite of Node.js packages for
-accessing serial ports. The Guix package @code{node-serialport} provides the
-recommended high-level interface.
-
-Parsers are used to take raw binary data and transform them into usable
-messages. This package provides @code{InterByteTimeout}, a parser that emits
-data if there is a pause between packets for the specified amount of time.")))
-
(define-public node-serialport-stream
(package
(inherit node-serialport)