summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-05-07 01:40:45 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-05-07 01:44:28 +0300
commit014875b29e68da6357a5323e6dd1eaa74a05b753 (patch)
tree544f4384d3c58ef5db29a09810c04472dbe1a374 /gnu
parent51c711a328d0b43015386ed0db83957439aaf2ab (diff)
gnu: psascan: Limit to 64-bit systems.
* gnu/packages/cpp.scm (psascan)[supported-systems]: New field. Change-Id: I19eef41449a16b4440f3dd73cdb181c7c3383e84
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cpp.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 8a0bd62d6b..0b6b556a6b 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1572,6 +1572,8 @@ parsers according to a Parsing Expression Grammar (PEG).")
external-memory suffix array construction algorithm called pSAscan. The
algorithm is based on the sequential external-memory suffix array construction
algorithm called SAscan.")
+ ;; Code exhibits integer size mismatches when compiled on 32-bit systems.
+ (supported-systems %64bit-supported-systems)
(license license:expat)))
(define-public cxxopts