summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:30:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:41 +0200
commit026e686e025db6e67eb486fa352a0bdfaf248ce2 (patch)
treec6b792fecdf58fba291a213b4eb739247f377057 /gnu
parent63b3e0294645f010d0b132687ec4c094e5a5f96d (diff)
gnu: Add texlive-pst-pad.
* gnu/packages/tex.scm (texlive-pst-pad): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c09e3c8638..b9299408ce 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -33692,6 +33692,30 @@ the two other signals. Lissajous diagrams (XY-mode) can also be obtained.")
in the slides of a projected presentation.")
(license license:lppl)))
+(define-public texlive-pst-pad
+ (package
+ (name "texlive-pst-pad")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/pst-pad/"
+ "source/generic/pst-pad/"
+ "tex/generic/pst-pad/" "tex/latex/pst-pad/")
+ (base32
+ "1vvgjf2g9dynjg1y6dm1d47v40sga4a34ngyy3h5lfmy58860jri")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pst-pad")
+ (synopsis "Draw simple attachment systems with PSTricks")
+ (description
+ "The package collects a set of graphical elements based on PStricks that
+can be used to facilitate display of attachment systems such as two
+differently shaped surfaces with or without a fluid wedged in between. These
+macros ease the display of wet adhesion models and common friction systems
+such as boundary lubrication, elastohydrodynamic lubrication and hydrodynamic
+lubrication.")
+ (license license:lppl)))
+
(define-public texlive-pst-text
(package
(name "texlive-pst-text")