summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-03 22:04:36 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:49 +0200
commit29cc6b1cd6a20f7b077eaf9557db585af019c5f6 (patch)
tree061cebde47d35d38b15f48cc970d6fcef4c4811d /gnu
parent582ec648c9986a0e267a07da59c9f9712805610d (diff)
gnu: Deprecate `texlive-tiny'.
At this point, there are three equivalent TeX Live sub-systems: texlive-scheme-basic, texlive-tiny, and (texlive-updmap.cfg). It is confusing to keep so many around. * doc/contributing.texi (Submitting Patches): Remove reference to TEXLIVE-TINY. * gnu/packages/algebra.scm (pari-gp)[native-inputs]: (giac)[native-inputs]: * gnu/packages/chez.scm (chez-sockets)[native-inputs]: * gnu/packages/engineering.scm (fastcap)[native-inputs]: * gnu/packages/gettext.scm (po4a)[native-inputs]: * gnu/packages/maths.scm (cddlib)[native-inputs]: (gnuplot)[native-inputs]: (itpp)[native-inputs]: * gnu/packages/ocaml.scm (unison)[native-inputs]: * gnu/packages/pdf.scm (extractpdfmark)[native-inputs]: * gnu/packages/photo.scm (enblend-enfuse): Replace TEXLIVE-TINY with a call to TEXLIVE-UPDMAP.CFG. * gnu/packages/radio.scm (gnuradio)[native-inputs]: Remove unnecessary TEXLIVE-TINY. * gnu/packages/tex.scm (texlive-tiny): Deprecate it in favor of TEXLIVE-SCHEME-BASIC. (texlive-makecmds)[native-inputs]: Replace TEXLIVE-TINY with a call to TEXLIVE-UPDMAP.CFG. * guix/lint.scm (check-inputs-should-be-native): Check only for "texlive-updmap.cfg" input name.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/algebra.scm4
-rw-r--r--gnu/packages/chez.scm4
-rw-r--r--gnu/packages/engineering.scm9
-rw-r--r--gnu/packages/gettext.scm2
-rw-r--r--gnu/packages/graphics.scm2
-rw-r--r--gnu/packages/maths.scm41
-rw-r--r--gnu/packages/ocaml.scm2
-rw-r--r--gnu/packages/pdf.scm2
-rw-r--r--gnu/packages/photo.scm2
-rw-r--r--gnu/packages/radio.scm1
-rw-r--r--gnu/packages/tex.scm15
11 files changed, 38 insertions, 46 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 896cf1bb9a..83eb63e206 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -236,7 +236,7 @@ the real span of the lattice.")
(base32
"03swii601kxnphl6v7wv0rh2xn4rz6xbljzvfw5v9py6w3z5nm63"))))
(build-system gnu-build-system)
- (native-inputs (list texlive-tiny))
+ (native-inputs (list (texlive-updmap.cfg)))
(inputs (list gmp libx11 perl readline))
(arguments
'(#:make-flags '("all")
@@ -405,7 +405,7 @@ precision.")
hevea
python-wrapper
readline
- texlive-tiny))
+ (texlive-updmap.cfg)))
(home-page "https://www-fourier.ujf-grenoble.fr/~parisse/giac.html")
(synopsis "Computer algebra system")
(description
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 3467783dd3..a5cb5a2e06 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -1075,10 +1075,10 @@ programming in Scheme.")
(native-inputs
(list (chez-scheme-for-system)
chez-web
- texlive-tiny))
+ (texlive-updmap.cfg)))
(arguments
(list
- #:tests? #f ; no tests
+ #:tests? #f ; no tests
#:phases
#~(modify-phases %standard-phases
(replace 'configure
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 8ee8e99b34..c2846f0bda 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -575,10 +575,11 @@ featuring various improvements and bug fixes.")))
"fastcap-mulGlobal.patch"))))
(build-system gnu-build-system)
(native-inputs
- ;; FIXME: with texlive-tiny citation references are rendered as question
- ;; marks. During the build warnings like these are printed:
- ;; LaTeX Warning: Citation `nabors91' on page 2 undefined on input line 3.
- `(("texlive" ,texlive-tiny)
+ ;; FIXME: with (texlive-updmap.cfg) citation references are rendered as
+ ;; question marks. During the build warnings like these are printed:
+ ;; LaTeX Warning: Citation `nabors91' on page 2 undefined on input line
+ ;; 3.
+ `(("texlive" ,(texlive-updmap.cfg))
("ghostscript" ,ghostscript)))
(arguments
`(#:make-flags '("CC=gcc" "RM=rm" "SHELL=sh" "all")
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 114d8cf7af..21ef05b811 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -292,7 +292,7 @@ from Markdown files.")
;; For tests.
docbook-xml-4.1.2
perl-test-pod
- texlive-tiny))
+ (texlive-updmap.cfg)))
(inputs
(list bash-minimal
perl-gettext
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 02b73d5197..da49f23f1f 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -2472,7 +2472,7 @@ generated discrete signed distance field using the cubic spline kernel.
(list doxygen graphviz
;; TODO: Fix failing LaTeX invocation (which results in equations
;; being inserted literally into PNGs rather than being typeset).
- ;;texlive-tiny
+ ;; (texlive-updmap.cfg)
perl)) ;used to generate Fortran headers
(inputs
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 27ded198d0..40c1433284 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -829,29 +829,30 @@ integer programming problems and computes Markov bases for statistics.")
(version "0.94m")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/cddlib/cddlib")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "09s8323h5w9j6mpl1yc6lm770dkskfxd2ayyafkcjllmnncxzfa0"))))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cddlib/cddlib")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "09s8323h5w9j6mpl1yc6lm770dkskfxd2ayyafkcjllmnncxzfa0"))))
(build-system gnu-build-system)
(inputs
(list gmp))
- (native-inputs (list autoconf
- automake
- libtool
- texlive-amsfonts
- texlive-l3backend
- texlive-graphics
- texlive-l3backend
- texlive-tiny))
+ (native-inputs
+ (list autoconf
+ automake
+ libtool
+ (texlive-updmap.cfg
+ (list texlive-amsfonts
+ texlive-graphics
+ texlive-l3backend
+ texlive-l3backend))))
(arguments
(list #:configure-flags
- #~(list (string-append "--docdir=" #$output
- "/share/doc/" #$name "-" #$version))))
+ #~(list (string-append "--docdir=" #$output
+ "/share/doc/" #$name "-" #$version))))
(home-page "https://www.inf.ethz.ch/personal/fukudak/cdd_home/index.html")
(synopsis "Library for convex hulls and extreme rays of polyhedra")
(description
@@ -1237,7 +1238,7 @@ in the terminal or with an external viewer.")
(base32 "1kzmj4yyxvlxqzqbrw6sx6dnvhj1zzqnciyb8ryzy6mdrb3pj4lk"))))
(build-system gnu-build-system)
(native-inputs
- (list pkg-config texlive-tiny))
+ (list pkg-config (texlive-updmap.cfg)))
(inputs
(list cairo gd lua pango readline))
(arguments
@@ -1947,7 +1948,7 @@ the resulting text.")
;; FIXME: Even though the fonts are available dvips complains:
;; "Font cmmi10 not found; characters will be left blank."
(native-inputs
- `(("texlive" ,texlive-tiny)
+ `(("texlive" ,(texlive-updmap.cfg))
("ghostscript" ,ghostscript)
("doxygen" ,doxygen)))
(home-page "https://itpp.sourceforge.net")
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index bc09b111ab..7a9045921b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1377,7 +1377,7 @@ libpanel, librsvg and quartz.")
`(("ocaml" ,ocaml-4.09)
;; For documentation
("ghostscript" ,ghostscript)
- ("texlive" ,texlive-tiny)
+ ("texlive" ,(texlive-updmap.cfg))
("hevea" ,hevea)
("lynx" ,lynx)
("which" ,which)))
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 767cf0c5db..0309434339 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -220,7 +220,7 @@ comparison modes: words, characters, and appearance.")
gettext-minimal
ghostscript
pkg-config
- texlive-tiny))
+ (texlive-updmap.cfg)))
(inputs
(list poppler))
(home-page "https://github.com/trueroad/extractpdfmark")
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 1e78c8e9fe..309601092b 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -381,7 +381,7 @@ overlapping images, as well as some command line tools.")
help2man
imagemagick
libxml2
- texlive-tiny
+ (texlive-updmap.cfg)
tidy-html
transfig))
(inputs
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 43c9f22c66..235b648a52 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -709,7 +709,6 @@ used by RDS Spy, and audio files containing @dfn{multiplex} signals (MPX).")
python-pyzmq
python-scipy
python-sphinx
- texlive-tiny
(texlive-updmap.cfg (list texlive-newunicodechar))
xorg-server-for-tests))
(inputs
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1cb96f0bfb..888c572a86 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -135,9 +135,7 @@
;;; module also provides TEXLIVE-UPDMAP.CFG function, which creates a TeX Live
;;; tree with font map files updates. It should be used exclusively for
;;; package definitions, as a native input. It is possible to augment that
-;;; tree, in particular with additional font packages. TEXLIVE-TINY package
-;;; is a shortcut for TEXLIVE-UPDMAP.CFG called without any additional
-;;; package.
+;;; tree, in particular with additional font packages.
;;;
;;; Unlike font map files, TeX formats are not built from a profile hook, as
;;; the process would be too time-consuming, e.g., when invoking "guix shell".
@@ -984,17 +982,10 @@ ones.")
'()
(append default-packages packages))))))))
+(define-deprecated-package texlive-tiny texlive-scheme-basic)
(define-deprecated/alias texlive-union texlive-updmap.cfg)
(export texlive-union)
-;; For use in package definitions only
-(define-public texlive-tiny
- (package
- (inherit (texlive-updmap.cfg))
- (name "texlive-tiny")
- (description "This is a very limited subset of the TeX Live distribution.
-It includes little more than the required set of LaTeX packages.")))
-
(define-public texlive-tex
(package
(name "texlive-tex")
@@ -8263,7 +8254,7 @@ diagrams.")
"05y5n265in7mrbpgjxqg339l8r8dmp6lvl4k528pr3rkb8z94qaf")))
(outputs '("out" "doc"))
(build-system texlive-build-system)
- (native-inputs (list texlive-tiny))
+ (native-inputs (list (texlive-updmap.cfg)))
(home-page "https://www.ctan.org/pkg/makecmds")
(synopsis "TeX macro to define or redefine a command")
(description "The package provides a @code{\\makecommand} command, which