summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-21 12:08:10 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-10 00:06:14 -0400
commit2aa497e23c22c664fefebe8e1b2a9df49030ba2d (patch)
tree678c5f89063ebbb74cf69818982bb8e26ea4d168 /gnu
parentb78aab0739218bcd8cbb51ab3af9d6fda7ba19dc (diff)
gnu: Add qmk-firmware-ergodox-ez-dvorak-emacs.
* gnu/packages/firmware.scm (qmk-firmware-ergodox-ez-dvorak-emacs): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/firmware.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 429e5aa1b2..dfa37e21ee 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -1479,6 +1479,15 @@ function and symbols on layer 1 and media and and mouse keys on layer 2. See
the @file{layouts/community/ergodox/dvorak/keymap.c} source file for the
keymap definition."))
+(define-public qmk-firmware-ergodox-ez-dvorak-emacs
+ (make-qmk-firmware
+ "ergodox_ez" "dvorak_emacs" #:description
+ "This is a Dvorak-based keymap optimized for Emacs usage, with the
+frequently used Control and Meta (Alt) keys mapped to the thumb buttons. It
+contains a single extra layer that includes function and multimedia keys. A
+graphical representation of the keymap is available in the
+@file{layouts/community/ergodox/dvorak_emacs/readme.md} source file."))
+
(define-public qmk-udev-rules
(package
(inherit qmk-firmware-ergodox-ez-default)