summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:28:03 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:12 +0200
commit2f0023b2c0e851254efe480439eaf8f5c49c1336 (patch)
tree4a03953db59beb97765109dab917ae2446a466bb /gnu
parentb2525ab75ee7d90cada226d109fc992d77346513 (diff)
gnu: Add texlive-chickenize.
* gnu/packages/tex.scm (texlive-chickenize): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 10bcc1ff3a..2a2c5231f9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8380,6 +8380,29 @@ detecting undefined and unused references from LaTeX auxiliary or bibliography
files.")
(license license:lppl1.3+)))
+(define-public texlive-chickenize
+ (package
+ (name "texlive-chickenize")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/luatex/chickenize/"
+ "source/luatex/chickenize/"
+ "tex/luatex/chickenize/")
+ (base32
+ "055lkxc2igr0qh1lcdbnh2w0z92v3wkjgp1hpbbrj8r5kvpm7nvy")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/chickenize")
+ (synopsis "Use Lua callbacks for some textual effects")
+ (description
+ "The package allows manipulations of any LuaTeX document. Most of the
+package's functions are merely for fun or educational use, but some
+functions (for example, @code{colorstretch} for visualising the badness and
+font expansion of each line, and @code{letterspaceadjust} doing what its name
+says) could be useful in a normal LuaTeX document.")
+ (license license:lppl1.3+)))
+
(define-public texlive-cmap
(package
(name "texlive-cmap")