summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:26:21 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:49:34 +0200
commit314e984d6c3836a28528f057d8b2418e1cfdbd5b (patch)
treee55e5ff5268ac5b1fb6c4fab288660eaeee9c2ea /gnu
parent2cc3983ff81f41000cc77daecfc05ab4cd9383cb (diff)
gnu: Add texlive-collection-games.
* gnu/packages/tex.scm (texlive-collection-games): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm63
1 files changed, 63 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 771c1d590a..4d9bb4bb2a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -46027,6 +46027,69 @@ includes the Aleph engine and related Omega formats and packages, and the
HiTeX engine and related.")
(license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+(define-public texlive-collection-games
+ (package
+ (name "texlive-collection-games")
+ (version (number->string %texlive-revision))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments (list #:builder #~(mkdir #$output)))
+ (propagated-inputs
+ (list texlive-bartel-chess-fonts
+ texlive-chess
+ texlive-chess-problem-diagrams
+ texlive-chessboard
+ texlive-chessfss
+ texlive-chinesechess
+ texlive-collection-latex
+ texlive-crossword
+ texlive-crosswrd
+ texlive-customdice
+ texlive-egameps
+ texlive-gamebook
+ texlive-gamebooklib
+ texlive-go
+ texlive-hanoi
+ texlive-havannah
+ texlive-hexboard
+ texlive-hexgame
+ texlive-hmtrump
+ texlive-horoscop
+ texlive-jeuxcartes
+ texlive-jigsaw
+ texlive-labyrinth
+ texlive-logicpuzzle
+ texlive-mahjong
+ texlive-maze
+ texlive-musikui
+ texlive-nimsticks
+ texlive-onedown
+ texlive-othello
+ texlive-othelloboard
+ texlive-pas-crosswords
+ texlive-psgo
+ texlive-realtranspose
+ texlive-reverxii
+ texlive-rubik
+ texlive-schwalbe-chess
+ texlive-scrabble
+ texlive-sgame
+ texlive-skak
+ texlive-skaknew
+ texlive-soup
+ texlive-sudoku
+ texlive-sudokubundle
+ texlive-tangramtikz
+ texlive-wargame
+ texlive-xq
+ texlive-xskak))
+ (home-page "https://www.tug.org/texlive/")
+ (synopsis "Games typesetting")
+ (description
+ "This collection includes setups for typesetting various games,
+including chess.")
+ (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+
(define-public texlive-collection-humanities
(package
(name "texlive-collection-humanities")