summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-09-08 14:51:04 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-09-21 21:38:39 +0200
commit3f1c722ec74dcf81833ffc7b2d4151241b31540e (patch)
tree43db3ff31c02e4c2b6c8aa350673b3daa75c9ed3 /gnu
parent538c0e3b699a35656b796cdd90b837135b7925da (diff)
gnu: r-htmltools: Ensure temporary files can be deleted.
* gnu/packages/web.scm (r-htmltools)[arguments]: Add phase "copy-files-without-mode".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 342262b39d..2c63e75ad4 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3230,6 +3230,20 @@ directory.")
(base32
"0j9bf80grd6gwh7116m575pycv87c0wcwkxsz3gzzfs4aw3pxyr9"))))
(build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; See https://github.com/rstudio/htmltools/pull/68
+ ;; The resource files are in the store and have mode 444. After
+ ;; copying the files R fails to remove them again because it doesn't
+ ;; have write access to them.
+ (add-after 'unpack 'copy-files-without-mode
+ (lambda _
+ (substitute* "R/html_dependency.R"
+ (("file.copy\\(from, to, " prefix)
+ (string-append prefix
+ "copy.mode = FALSE, ")))
+ #t)))))
(propagated-inputs
`(("r-digest" ,r-digest)
("r-rcpp" ,r-rcpp)))