summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-07-19 13:08:47 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-07-19 13:08:47 +0200
commit4415a421c454817728a164db77f0437572343168 (patch)
tree876912508b73bebb99af4b07c4b2f70041001e52 /gnu
parentff6b2a88c4600ad5774e6dde9eb7e2c18e85ada3 (diff)
gnu: Add r-uchardet.
* gnu/packages/cran.scm (r-uchardet): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index acd1eb0be5..b057a299d4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8009,6 +8009,28 @@ can be computed between character vectors while taking proper care of encoding
or between integer vectors representing generic sequences.")
(license license:gpl3+)))
+(define-public r-uchardet
+ (package
+ (name "r-uchardet")
+ (version "1.1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "uchardet" version))
+ (sha256
+ (base32
+ "0m3xy807smqdxhkhd9cwrcf3ljlyvfmnkd7831qzpgcadam2jcdj"))))
+ (properties `((upstream-name . "uchardet")))
+ (build-system r-build-system)
+ (native-inputs (list r-knitr))
+ (home-page "https://artemklevtsov.gitlab.io/uchardet")
+ (synopsis "Universal character encoding detector")
+ (description
+ "This package provides R bindings to the uchardet encoding detector
+library from Mozilla. It takes a sequence of bytes in an unknown character
+encoding without any additional information, and attempts to get the encoding
+of the text. All return names of the encodings are iconv-compatible.")
+ (license license:gpl2)))
+
(define-public r-ucminf
(package
(name "r-ucminf")