summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2023-03-24 09:20:54 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-24 09:20:54 +0100
commit4742ea59cb7b6ea3592e4ca6cf8b4fad5611b709 (patch)
treebf1909198b3290f21b729fd4a2ac5f0def68454d /gnu
parent71651996d187301be2a030711f2faec8216f2d23 (diff)
gnu: Add emacs-jit-spell.
* gnu/packages/emacs-xyz.scm (emacs-jit-spell): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0a1846ea4c..18d4623688 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9698,6 +9698,30 @@ insertion mode. When enabled all keys are implicitly prefixed with
sgml/html integration, and indentation (working with sgml).")
(license license:gpl3+)))
+(define-public emacs-jit-spell
+ (package
+ (name "emacs-jit-spell")
+ (version "0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/jit-spell-"
+ version ".tar"))
+ (sha256
+ (base32
+ "10h2nbp6lap26arwifhzs119mkfj76fvjsix3iccjjvfdi88wdn9"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-compat))
+ (home-page "https://github.com/astoff/jit-spell")
+ (synopsis "Just-in-time spell checking")
+ (description
+ "This package highlights all misspelled words in a window, just like a
+word processor or web browser does. This behavior is different from the
+built-in Flyspell package, which only checks words as the cursor moves over
+them. Moreover, unlike Flyspell, Jit-spell communicates with the
+spell-checking subprocess entirely asynchronously, which can lead to a
+noticeable performance improvement.")
+ (license license:gpl3+)))
+
(define-public emacs-company-cabal
;; The latest version is 0.3.0, but no release has been provided after 0.2.1.
(let ((commit "62112a7259e24bd6c08885629a185afe512b7d3d")