summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:32:06 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:14 +0200
commit4f5ae7ef9cac8743b96ae693957a14e0255de1c9 (patch)
treeedb7af2fe8dcf589b14c3cc5afbf1bd5a1df3a95 /gnu
parent9acef59889ef6744b8113a7a6c479269d5664b43 (diff)
gnu: Add texlive-emoji.
* gnu/packages/tex.scm (texlive-emoji): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3ced59f1b0..7fffb62dd3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9023,6 +9023,24 @@ segment by segment according to various criteria: main edited text, variant
readings, translations or annotated borrowings between texts.")
(license (list license:gpl3+ license:fdl1.3+))))
+(define-public texlive-emoji
+ (package
+ (name "texlive-emoji")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/emoji/" "tex/latex/emoji/")
+ (base32
+ "17i2kjb1rlgj2ipg6bkni1n8l1yhhnm1m96ynj1nv8gkmgkfklal")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/emoji")
+ (synopsis "Emoji support in (Lua)LaTeX")
+ (description
+ "This package allows users to typeset emojis in LaTeX documents. It
+requires the LuaHBTeX engine.")
+ (license license:lppl1.3c)))
+
(define-public texlive-ae
(package
(name "texlive-ae")