summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:31:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:14 +0200
commit9acef59889ef6744b8113a7a6c479269d5664b43 (patch)
tree2f51a315ba996ed3c11a651f97e5619b7946f19e /gnu
parenta98cf00c19037771ad21851e622b68a976349a2f (diff)
gnu: Add texlive-ekdosis.
* gnu/packages/tex.scm (texlive-ekdosis): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 666b46cf5a..3ced59f1b0 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8996,6 +8996,33 @@ texlive-2019.3/Master/texmf-dist/doc/fonts/ec/copyrite.txt"))))
(define-deprecated-package texlive-fonts-ec texlive-ec)
+(define-public texlive-ekdosis
+ (package
+ (name "texlive-ekdosis")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/ekdosis/"
+ "source/lualatex/ekdosis/"
+ "tex/lualatex/ekdosis/")
+ (base32
+ "0bzydy6gcmikqsdiaji30a2ycifzaafbg0ccv5lq5an7rv2hajmj")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/ekdosis")
+ (synopsis "Typesetting TEI-xml compliant Critical Editions")
+ (description
+ "@code{ekdosis} is a LuaLaTeX package designed for multilingual critical
+editions. It can be used to typeset texts and different layers of critical
+notes in any direction accepted by LuaTeX. Texts can be arranged in running
+paragraphs or on facing pages, in any number of columns which in turn can be
+synchronized or not. In addition to printed texts, @code{ekdosis} can convert
+@file{.tex} source files so as to produce TEI XML-compliant critical editions.
+Database-driven encoding under LaTeX then allows extraction of texts entered
+segment by segment according to various criteria: main edited text, variant
+readings, translations or annotated borrowings between texts.")
+ (license (list license:gpl3+ license:fdl1.3+))))
+
(define-public texlive-ae
(package
(name "texlive-ae")