summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorWiktor Żelazny <wzelazny@vurv.cz>2022-09-15 10:41:07 +0200
committerChristopher Baines <mail@cbaines.net>2022-10-06 15:08:03 +0100
commit53eea4d6570037e6168cbb0fbd8e295874f0759a (patch)
tree6096ed5c30ee6f302a61a54498ec3edab15896b1 /gnu
parent7a271e688612ae77e69834cc8d4aa82bd2cfdbd9 (diff)
gnu: Add r-spacefillr.
* gnu/packages/cran.scm (r-spacefillr): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6a561473fc..709259ea5e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -34733,6 +34733,30 @@ analyses.")
for rendering equations in the HTML help files.")
(license (list license:asl2.0 license:gpl3))))
+(define-public r-spacefillr
+ (package
+ (name "r-spacefillr")
+ (version "0.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "spacefillr" version))
+ (sha256
+ (base32
+ "0c4yasc1zizjmhd2ciyz86lg76fsrxvl19yjkb2fmkda9rmnc0bf"))))
+ (properties `((upstream-name . "spacefillr")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rcpp))
+ (home-page "https://github.com/tylermorganwall/spacefillr")
+ (synopsis "Space-Filling Random and Quasi-Random Sequences")
+ (description
+ "@code{spacefillr} enables generation of random and quasi-random
+space-filling sequences. It supports the following sequences: Halton, Sobol,
+Owen-scrambled Sobol, Owen-scrambled Sobol with errors distributed as blue
+noise, progressive jittered, progressive multi-jittered (PMJ), PMJ with blue
+noise, PMJ02, and PMJ02 with blue noise. The package also includes a C++
+API.")
+ (license license:expat)))
+
(define-public r-spacetime
(package
(name "r-spacetime")