summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 17:19:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:27 +0200
commit5d5f04ca0b86b8a74da7e05f49f75b38d1771621 (patch)
tree8d22ce94a72af23e94aa2580332bbc0e9c043f17 /gnu
parentc69290c539efc97079efba930885f3ea09dca701 (diff)
gnu: Add texlive-xduthesis.
* gnu/packages/tex.scm (texlive-xduthesis): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ca233482be..400e460169 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -32138,6 +32138,29 @@ functionality has been taken over by @code{xr}, so this final version is just
a stub that loads @code{xr}.")
(license license:lppl1.3c)))
+(define-public texlive-xduthesis
+ (package
+ (name "texlive-xduthesis")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/xduthesis/"
+ "source/latex/xduthesis/"
+ "tex/latex/xduthesis/")
+ (base32
+ "1sdl1m869s4hcxdj3q2205x9xdgx0qy9ri9vjyma9rsv70sa648p")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/xduthesis")
+ (synopsis "XeLaTeX template for writing Xidian University thesis")
+ (description
+ "This is a XeLaTeX template for writing theses to apply academic degrees
+in Xidian University. The template is designed according to the official
+requirements on typesetting theses. The template currently supports all
+levels of degrees from bachelor to doctor, including both academic master and
+professional master.")
+ (license license:lppl1.3+)))
+
(define-public texlive-xecjk
(package
(name "texlive-xecjk")