summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:36:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:16 +0200
commit65064b0013506580251f67ca1faaf9a789755422 (patch)
tree1f17c14f2365b492729bba71f1e74a737be052ab /gnu
parent487f16723091a16bfc3fc886f882547c4cc0eaf2 (diff)
gnu: Add texlive-kanaparser.
* gnu/packages/tex.scm (texlive-kanaparser): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d6460bb555..8c17fc7e73 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -15466,6 +15466,30 @@ package which defines the macro, pre-compiled @file{tfm} files, and
documentation.")
(license (license:non-copyleft "file:///doc/fonts/eurosym/COPYING"))))
+(define-public texlive-kanaparser
+ (package
+ (name "texlive-kanaparser")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/luatex/kanaparser/"
+ "tex/luatex/kanaparser/")
+ (base32
+ "0bcvxkdb2y60w7c0swi3f8yncli0yswalrdzxjv7h0xp21c202hp")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/kanaparser")
+ (synopsis "Kana parser for LuaTeX")
+ (description
+ "The package provides a kana parser for LuaTeX. It is a set of four
+macros that handle transliteration of text: from hiragana and katakana to
+Latin from Latin and katakana to hiragana from Latin and hiragana to katakana
+It can be used to write kana directly using only the ASCII character set or
+for education purposes. The package has support for obsolete and rarely used
+syllables, some only accessible via the provided toggle macro.")
+ ;; License is BSD. Assuming original BSD-4.
+ (license license:bsd-4)))
+
(define-public texlive-kastrup
(package
(name "texlive-kastrup")