summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-16 22:44:39 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-16 23:07:39 +0100
commit6f0efe0288689b7af380806d266698cd8d0ff6b9 (patch)
treee5324b989d869afd9411b67243b2f0b244311ec2 /gnu
parentf2b28d83342d3909e3e8056d653dd095dd120412 (diff)
gnu: Add go-github-com-pion-dtls.
* gnu/packages/golang-web.scm (go-github-com-pion-dtls): New variable. Change-Id: I1931f8b5829d2fd7ce09f54ec00e4eaab5fb7579
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 9b0edcc60c..f7984e1de0 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1588,6 +1588,38 @@ which produce colorized output using github.com/fatih/color.")
(description "OpenTracing-Go is a Go implementation of the OpenTracing API.")
(license license:asl2.0)))
+(define-public go-github-com-pion-dtls
+ (package
+ (name "go-github-com-pion-dtls")
+ (version "1.5.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/dtls")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0qc5dbgh31lilbd1lpmajj1fjzy4jx9iadzqgl9jd1ry9fj3ly1d"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ ;; XXX: TestClientCertificate: Client failed(x509: certificate relies on
+ ;; legacy Common Name field, use SANs instead)
+ #:tests? #f
+ #:import-path "github.com/pion/dtls"))
+ (propagated-inputs
+ (list go-github-com-pion-logging
+ go-github-com-pion-transport
+ go-golang-org-x-crypto))
+ (home-page "https://github.com/pion/dtls")
+ (synopsis "DTLS 1.2 Server/Client implementation for Go")
+ (description
+ "This package provides a native
+@url{https://datatracker.ietf.org/doc/html/rfc6347, DTLS 1.2} implementation
+in Golang.")
+ (license license:expat)))
+
(define-public go-github-com-pion-mdns
(package
(name "go-github-com-pion-mdns")