summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-06-23 12:46:31 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-10-27 16:40:18 +0200
commit70d30096b38f4d1d23d84aaae34400e3d8abd797 (patch)
tree31c295ae5af8cea901cc047b05766f26a4dc0ecb /gnu
parent599655dc496491c2569689811d667df6ffeb396c (diff)
gnu: Add r-atsnp.
* gnu/packages/bioconductor.scm (r-atsnp): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ad20602ff6..6e72a8e1af 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2317,6 +2317,39 @@ reproducible gene expression signatures capable of accurately distinguishing
tumor samples from healthy controls.")
(license license:artistic2.0)))
+(define-public r-atsnp
+ (package
+ (name "r-atsnp")
+ (version "1.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "atSNP" version))
+ (sha256
+ (base32
+ "0dmv34xqwr3l2rznapxmyrkyf1w78qzxdv88s5nn8s1m8qdkgwkz"))))
+ (properties `((upstream-name . "atSNP")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocfilecache
+ r-biocparallel
+ r-bsgenome
+ r-data-table
+ r-ggplot2
+ r-lifecycle
+ r-motifstack
+ r-rappdirs
+ r-rcpp
+ r-testthat))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/sunyoungshin/atSNP")
+ (synopsis
+ "Affinity test for identifying regulatory single nucleotide polymorphisms")
+ (description
+ "The atSNP package performs affinity tests of motif matches with the
+@dfn{SNP} (single nucleotide polymorphism) or the reference genomes and
+SNP-led changes in motif matches.")
+ (license license:gpl2)))
+
(define-public r-attract
(package
(name "r-attract")