summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:38:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:48 +0200
commit793859a0cbc6dcedc8a9afe73a8603088eb8447f (patch)
tree2e0d5be3b750dda266c5d637b7a3accd23a4fcbf /gnu
parent576fffb7833d5693055785930d54cc62a915aadc (diff)
gnu: Add texlive-pstricks-add.
* gnu/packages/tex.scm (texlive-pstricks-add): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 84bb9521fa..fd5411b96e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -34413,6 +34413,32 @@ these snippets. In a final pdfLaTeX run the script replaces the environments
with @code{\\includegraphics} to include the processed snippets.")
(license license:gpl2)))
+(define-public texlive-pstricks-add
+ (package
+ (name "texlive-pstricks-add")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/pstricks-add/"
+ "dvips/pstricks-add/"
+ "tex/generic/pstricks-add/"
+ "tex/latex/pstricks-add/")
+ (base32
+ "18khs28v3dg5z7215k0yv7hxna9x5nh09hlrw2fc4nhmzymy2kjg")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pstricks-add")
+ (synopsis "Collection of add-ons and bugfixes for PSTricks")
+ (description
+ "This package collects together examples that have been posted to the
+PSTricks mailing list, together with many additional features for the basic
+@code{pstricks}, @code{pst-plot} and @code{pst-node}, including: bugfixes; new
+options for the pspicture environment; arrows; braces as node
+connection/linestyle; extended axes for plots (e.g., logarithm axes); polar
+plots; plotting tangent lines of curves or functions; solving and printing
+differential equations; box plots; matrix plots; and pie charts.")
+ (license license:lppl)))
+
(define-public texlive-marginnote
(package
(name "texlive-marginnote")