summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-08-22 21:07:11 +0100
committerChristopher Baines <mail@cbaines.net>2017-09-10 19:27:00 +0100
commit814da59fcc8317b2127dbd19cfd003941e1a118f (patch)
tree30c4173eeab312d54ff7b616711ee58fea799255 /gnu
parent81808194ac78cd77fcb42e9b8e20117ff80834ec (diff)
gnu: Add emacs-wgrep.
* gnu/packages/emacs.scm (emacs-wgrep): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index b4c3664c4b..34dc5ec658 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3568,6 +3568,27 @@ Dust.js, React/JSX, Angularjs, ejs, etc.")
(home-page "http://web-mode.org/")
(license license:gpl3+)))
+(define-public emacs-wgrep
+ (package
+ (name "emacs-wgrep")
+ (version "2.1.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/mhayashi1120/Emacs-wgrep/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1r2bpypar70xg6dsx12x1k74f39ww930rday7rgqpyknzsx1k4l1"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/mhayashi1120/Emacs-wgrep")
+ (synopsis "Edit a grep buffer and apply those changes to the files")
+ (description
+ "Emacs wgrep allows you to edit a grep buffer and apply those changes to
+the file buffer.")
+ (license license:gpl3+)))
+
(define-public emacs-helm
(package
(name "emacs-helm")