summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-12-05 16:21:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-12 15:37:15 +0100
commit8363719476f9bf5e4170435ad89d71f595d85853 (patch)
tree183aaf23da5dc077b2765e310f390636860331d6 /gnu
parent85d5ce49015dfd93c1b3d37cafe83d017eedcfd4 (diff)
gnu: Add r-harshlight.
* gnu/packages/bioconductor.scm (r-harshlight): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index fbd23d0f6d..07f8f658f4 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -5854,6 +5854,33 @@ testing and other simple calculations.")
Enrichment Analysis} (GSEA).")
(license license:artistic2.0)))
+(define-public r-harshlight
+ (package
+ (name "r-harshlight")
+ (version "1.70.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "Harshlight" version))
+ (sha256
+ (base32
+ "0asjgcnwawg8x7ql0srhb2011rvb4kr2cpsa1cy28nfmjfvdf0qm"))))
+ (properties `((upstream-name . "Harshlight")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-affy
+ r-altcdfenvs
+ r-biobase))
+ (home-page "http://asterion.rockefeller.edu/Harshlight/")
+ (synopsis "Corrective make-up program for microarray chips")
+ (description
+ "The package detects extended diffuse and compact blemishes on microarray
+chips. Harshlight marks the areas in a collection of chips (affybatch
+objects). A corrected @code{AffyBatch} object will result. The package
+replaces the defected areas with @code{N/A}s or the median of the values of
+the same probe. The new version handles the substitute value as a whole
+matrix to solve the memory problem.")
+ (license license:gpl2+)))
+
(define-public r-hpar
(package
(name "r-hpar")