summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-04-23 14:27:47 +0200
committerLeo Famulari <leo@famulari.name>2023-04-23 11:04:19 -0400
commit8e5b87f1d32e03eb1e316a93af6e103d4a27ea15 (patch)
tree86d5715e795ec3a0bf20a51e43ea84aad31ca638 /gnu
parent7f990f736c19e5c3daeb8abd14812bed41247616 (diff)
gnu: Add go-github-com-xeipuuv-gojsonschema.
* gnu/packages/golang.scm (go-github-com-xeipuuv-gojsonschema): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7d50dc83f5..bb914abfd7 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12945,6 +12945,46 @@ programming language.")
programming language.")
(license license:asl2.0))))
+(define-public go-github-com-xeipuuv-gojsonschema
+ (let ((commit "6b67b3fab74d992bd07f72550006ab2c6907c416")
+ (revision "0"))
+ (package
+ (name "go-github-com-xeipuuv-gojsonschema")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xeipuuv/gojsonschema")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1q937a6q7canlr3dllqdw0qwa6z2fpwn1w9kycavx8jmwh6q3f69"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/xeipuuv/gojsonschema"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda* (#:key import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (substitute* "schema_test.go"
+ (("\\{\"phase\": \"remote ref, " all)
+ (string-append "// " all))
+ (("\\{\"phase\": \"valid definition" all)
+ (string-append "// " all))
+ (("\\{\"phase\": \"invalid definition" all)
+ (string-append "// " all)))))))))
+ (propagated-inputs (list go-github-com-xeipuuv-gojsonreference
+ go-github-com-xeipuuv-gojsonpointer
+ go-github-com-stretchr-testify))
+ (home-page "https://github.com/xeipuuv/gojsonschema")
+ (synopsis "Implementation of JSON Schema for Go")
+ (description
+ "This package provides an implementation of JSON Schema for the Go
+programming language, which supports draft-04, draft-06 and draft-07.")
+ (license license:asl2.0))))
+
(define-public go-github-com-niemeyer-pretty
(package
(name "go-github-com-niemeyer-pretty")